Offsite backup storage issues
Incident Report for MyDatacloud
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 14:30 CET
Update
We are continuing to investigate this issue.
Posted Nov 28, 2022 - 14:30 CET
Investigating
Currently investigating connectivity issues to the storage server.
Posted Nov 28, 2022 - 09:29 CET