Some E-mail services are currently degraded.
Incident Report for MyDatacloud
Resolved
The issue has been resolved. One of the mailservers had issues authenticating in the cluster. The issue was temporary as the cluster membership was fixed after a reboot. We will investigate the root cause of this issue and take appropriate action if needed.
Posted Jun 28, 2022 - 10:31 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2022 - 10:14 CEST
Investigating
Some users are currently experiencing trouble accessing their e-mail on MyDataCloud. We are currently investigating the issue.
Posted Jun 28, 2022 - 10:02 CEST
This incident affected: MyDatacloud (Hosted Microsoft Exchange).